3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
7 # http://www.apache.org/licenses/LICENSE-2.0
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
15 %define COMPONENT custom_metrics
16 %define RPM_NAME caas-%{COMPONENT}
17 %define RPM_MAJOR_VERSION 0.5.0
18 %define RPM_MINOR_VERSION 4
19 %define go_version 1.12.10
20 %define DEP_MAN_VERSION 0.5.4
21 %define IMAGE_TAG %{RPM_MAJOR_VERSION}-%{RPM_MINOR_VERSION}
24 Version: %{RPM_MAJOR_VERSION}
25 Release: %{RPM_MINOR_VERSION}%{?dist}
26 Summary: Containers as a Service Custom Metrics component
27 License: %{_platform_license} and Apache License
28 URL: https://github.com/DirectXMan12/k8s-prometheus-adapter
30 Vendor: %{_platform_vendor} and DirectXMan12/k8s-prometheus-adapter unmodified
31 Source0: %{name}-%{version}.tar.gz
33 Requires: docker-ce >= 18.09.2, rsync
34 BuildRequires: docker-ce-cli >= 18.09.2, xz
37 This RPM contains the custom metrics container image for the CaaS subsystem.
47 --build-arg HTTP_PROXY="${http_proxy}" \
48 --build-arg HTTPS_PROXY="${https_proxy}" \
49 --build-arg NO_PROXY="${no_proxy}" \
50 --build-arg http_proxy="${http_proxy}" \
51 --build-arg https_proxy="${https_proxy}" \
52 --build-arg no_proxy="${no_proxy}" \
53 --build-arg CUSTOM_METRICS_VERSION="%{RPM_MAJOR_VERSION}" \
54 --build-arg go_version="%{go_version}" \
55 --tag %{COMPONENT}:%{IMAGE_TAG} \
56 %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT}/
58 mkdir -p %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/
60 docker save %{COMPONENT}:%{IMAGE_TAG} | xz -z -T2 > %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/%{COMPONENT}:%{IMAGE_TAG}.tar
62 docker rmi -f %{COMPONENT}:%{IMAGE_TAG}
65 mkdir -p %{buildroot}/%{_caas_container_tar_path}/
66 rsync -av %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/%{COMPONENT}:%{IMAGE_TAG}.tar %{buildroot}/%{_caas_container_tar_path}/
69 %{_caas_container_tar_path}/%{COMPONENT}:%{IMAGE_TAG}.tar