3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
7 # http://www.apache.org/licenses/LICENSE-2.0
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
15 %define COMPONENT flannel
16 %define RPM_NAME caas-%{COMPONENT}
17 %define RPM_MAJOR_VERSION 0.11.0
18 %define RPM_MINOR_VERSION 11
19 %define IMAGE_TAG %{RPM_MAJOR_VERSION}-%{RPM_MINOR_VERSION}
22 Version: %{RPM_MAJOR_VERSION}
23 Release: %{RPM_MINOR_VERSION}%{?dist}
24 Summary: Containers as a Service flannel component
25 License: %{_platform_license} and MIT license and BSD and Apache License and ISC License and COMMON DEVELOPMENT AND DISTRIBUTION LICENSE and GNU Lesser General Public License v3.0 only
26 URL: https://github.com/coreos/flannel
28 Vendor: %{_platform_vendor} and coreos/flannel unmodified
29 Source0: %{name}-%{version}.tar.gz
31 Requires: docker-ce >= 18.09.2, rsync
32 BuildRequires: docker-ce-cli >= 18.09.2, xz
35 This RPM contains the Flannel container image, and related deployment artifacts for the CaaS subsystem.
45 --build-arg HTTP_PROXY="${http_proxy}" \
46 --build-arg HTTPS_PROXY="${https_proxy}" \
47 --build-arg NO_PROXY="${no_proxy}" \
48 --build-arg http_proxy="${http_proxy}" \
49 --build-arg https_proxy="${https_proxy}" \
50 --build-arg no_proxy="${no_proxy}" \
51 --build-arg FLANNEL="%{RPM_MAJOR_VERSION}" \
52 --tag %{COMPONENT}:%{IMAGE_TAG} \
53 %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT}/
55 mkdir -p %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/
57 docker save %{COMPONENT}:%{IMAGE_TAG} | xz -z -T2 > %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/%{COMPONENT}:%{IMAGE_TAG}.tar
59 docker rmi -f %{COMPONENT}:%{IMAGE_TAG}
62 mkdir -p %{buildroot}/%{_caas_container_tar_path}
63 rsync -av %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/%{COMPONENT}:%{IMAGE_TAG}.tar %{buildroot}/%{_caas_container_tar_path}/
65 mkdir -p %{buildroot}/%{_playbooks_path}
66 rsync -av ansible/playbooks/flannel.yaml %{buildroot}/%{_playbooks_path}/
68 mkdir -p %{buildroot}/%{_roles_path}
69 rsync -av ansible/roles/flannel %{buildroot}/%{_roles_path}/
72 %{_caas_container_tar_path}/%{COMPONENT}:%{IMAGE_TAG}.tar
73 %{_playbooks_path}/flannel.yaml
74 %{_roles_path}/flannel
79 mkdir -p %{_postconfig_path}
80 ln -sf %{_playbooks_path}/flannel.yaml %{_postconfig_path}/
84 rm -f %{_postconfig_path}/flannel.yaml