3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
7 # http://www.apache.org/licenses/LICENSE-2.0
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
15 %define COMPONENT swift
16 %define RPM_NAME caas-%{COMPONENT}
17 %define RPM_MAJOR_VERSION 2.22.0
18 %define RPM_MINOR_VERSION 5
19 %define IMAGE_TAG %{RPM_MAJOR_VERSION}-%{RPM_MINOR_VERSION}
20 %define centos_build 191001
22 Version: %{RPM_MAJOR_VERSION}
23 Release: %{RPM_MINOR_VERSION}%{?dist}
24 Summary: Containers as a Service Swift component
25 License: %{_platform_license} and Apache License and GNU Lesser General Public License v3.0 only and BSD 3-clause New or Revised License and MIT License and Common Development and Distribution License and BSD and GNU General Public License v2.0 only
26 URL: https://github.com/openstack/swift
28 Vendor: %{_platform_vendor} and openstack/swift unmodified
29 Source0: %{name}-%{version}.tar.gz
31 Requires: docker-ce >= 18.09.2, rsync
32 BuildRequires: docker-ce-cli >= 18.09.2, xz, wget
35 This rpm contains the swift container and ansible for caas subsystem.
36 This container contains the swift service.
42 wget --progress=dot:giga http://artifacts.ci.centos.org/sig-cloudinstance/centos-7-%{centos_build}/%{_arch}/centos-7-%{_arch}-docker.tar.xz -O %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT}/centos-7-docker.tar.xz
43 # Building the container
48 --build-arg HTTP_PROXY="${http_proxy}" \
49 --build-arg HTTPS_PROXY="${https_proxy}" \
50 --build-arg NO_PROXY="${no_proxy}" \
51 --build-arg http_proxy="${http_proxy}" \
52 --build-arg https_proxy="${https_proxy}" \
53 --build-arg no_proxy="${no_proxy}" \
54 --build-arg SWIFT="%{version}" \
55 --tag %{COMPONENT}:%{IMAGE_TAG} \
56 %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT}/
58 # Creating a new folder for the container tar file
59 mkdir -p %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/
62 docker save %{COMPONENT}:%{IMAGE_TAG} | xz -z -T2 > %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/%{COMPONENT}:%{IMAGE_TAG}.tar
65 docker rmi -f %{COMPONENT}:%{IMAGE_TAG}
68 mkdir -p %{buildroot}/%{_caas_container_tar_path}/
69 rsync -av %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/%{COMPONENT}:%{IMAGE_TAG}.tar %{buildroot}/%{_caas_container_tar_path}/
71 mkdir -p %{buildroot}/%{_playbooks_path}/
72 rsync -av ansible/playbooks/swift.yaml %{buildroot}/%{_playbooks_path}/
74 mkdir -p %{buildroot}/%{_roles_path}/
75 rsync -av ansible/roles/swift %{buildroot}/%{_roles_path}/
79 %{_caas_container_tar_path}/%{COMPONENT}:%{IMAGE_TAG}.tar
86 mkdir -p %{_postconfig_path}/
87 ln -sf %{_playbooks_path}/swift.yaml %{_postconfig_path}/
91 rm -f %{_postconfig_path}/swift.yaml