CPU Pooler version update
[ta/caas-cpupooler.git] / rpmbuild.spec
index dfe4c54..339b320 100644 (file)
 %define COMPONENT_PART process-starter
 %define RPM_NAME caas-%{COMPONENT}
 %define RPM_MAJOR_VERSION 0.3.0
-%define RPM_MINOR_VERSION 2
-%define CPUPOOLER_VERSION d94704e4b2f9f91ee712c6385038413fb7aa064a
-%define DEPENDENCY_MANAGER_VERSION 0.5.0
+%define RPM_MINOR_VERSION 8
+%define go_version 1.12.10
+%define CPUPOOLER_VERSION e0459346946b0907d26cd3d79dc54feb2c625286
+%define DEP_MAN_VERSION 0.5.4
 %define IMAGE_TAG %{RPM_MAJOR_VERSION}-%{RPM_MINOR_VERSION}
 %define PROCESS_STARTER_INSTALL_PATH /opt/bin/
+%define centos_build 191001
 
 Name:           %{RPM_NAME}
 Version:        %{RPM_MAJOR_VERSION}
@@ -28,12 +30,12 @@ Release:        %{RPM_MINOR_VERSION}%{?dist}
 Summary:        Containers as a Service cpu-pooler component
 License:        %{_platform_license} and BSD 3-Clause License
 URL:            https://github.com/nokia/CPU-Pooler
-BuildArch:      x86_64
+BuildArch:      %{_arch}
 Vendor:         %{_platform_vendor} and Nokia
 Source0:        %{name}-%{version}.tar.gz
 
 Requires: docker-ce >= 18.09.2, rsync
-BuildRequires: docker-ce-cli >= 18.09.2, xz
+BuildRequires: docker-ce-cli >= 18.09.2, xz, wget
 
 # I was able to pack an executable via this.
 # more info at https://fedoraproject.org/wiki/Packaging:Debuginfo
@@ -46,6 +48,7 @@ This RPM contains the cpu-pooler container image, process-starter binary and rel
 %autosetup
 
 %build
+wget --progress=dot:giga http://artifacts.ci.centos.org/sig-cloudinstance/centos-7-%{centos_build}/%{_arch}/centos-7-%{_arch}-docker.tar.xz -O %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT_PART}/centos-7-docker.tar.xz
 # build the process-starter binary inside a builder conatiner
 docker build \
   --network=host \
@@ -57,8 +60,9 @@ docker build \
   --build-arg http_proxy="${http_proxy}" \
   --build-arg https_proxy="${https_proxy}" \
   --build-arg no_proxy="${no_proxy}" \
-  --build-arg DEPENDENCY_MANAGER="%{DEPENDENCY_MANAGER_VERSION}" \
-  --build-arg CPUPOOLER="%{CPUPOOLER_VERSION}" \
+  --build-arg go_version="%{go_version}" \
+  --build-arg DEP_MAN_VERSION="%{DEP_MAN_VERSION}" \
+  --build-arg CPUPOOLER_VERSION="%{CPUPOOLER_VERSION}" \
   --tag %{COMPONENT_PART}:builder \
   %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT_PART}/
 
@@ -103,8 +107,9 @@ docker build \
   --build-arg http_proxy="${http_proxy}" \
   --build-arg https_proxy="${https_proxy}" \
   --build-arg no_proxy="${no_proxy}" \
-  --build-arg DEPENDENCY_MANAGER="%{DEPENDENCY_MANAGER_VERSION}" \
-  --build-arg CPUPOOLER="%{CPUPOOLER_VERSION}" \
+  --build-arg DEP_MAN_VERSION="%{DEP_MAN_VERSION}" \
+  --build-arg CPUPOOLER_VERSION="%{CPUPOOLER_VERSION}" \
+  --build-arg go_version="%{go_version}" \
   --tag %{COMPONENT}:%{IMAGE_TAG} \
   %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT}/