Fix SR-IOV VF counting in sriovdp init script
[ta/caas-danm.git] / SPECS / caas-sriovdp.spec
index 3e0b554..74b102a 100644 (file)
 
 %define COMPONENT sriovdp
 %define RPM_NAME caas-%{COMPONENT}
-%define RPM_MAJOR_VERSION 2.0.0
-%define RPM_MINOR_VERSION 4
+%define RPM_MAJOR_VERSION 3.1.0
+%define RPM_MINOR_VERSION 0
 %define IMAGE_TAG %{RPM_MAJOR_VERSION}-%{RPM_MINOR_VERSION}
+%define go_version 1.12.10
+%define SRIOVDP 3.1
 
 Name:           %{RPM_NAME}
 Version:        %{RPM_MAJOR_VERSION}
@@ -24,7 +26,7 @@ Release:        %{RPM_MINOR_VERSION}%{?dist}
 Summary:        Containers as a Service sriov network device plugin component
 License:        %{_platform_license} and Apache License 2.0
 URL:            https://github.com/intel/sriov-network-device-plugin/
-BuildArch:      x86_64
+BuildArch:      %{_arch}
 Vendor:         %{_platform_vendor} and intel/sriov-network-device-plugin unmodified
 Source0:        %{name}-%{version}.tar.gz
 
@@ -48,7 +50,8 @@ docker build \
   --build-arg http_proxy="${http_proxy}" \
   --build-arg https_proxy="${https_proxy}" \
   --build-arg no_proxy="${no_proxy}" \
-  --build-arg SRIOVDP="%{RPM_MAJOR_VERSION}" \
+  --build-arg SRIOVDP="%{SRIOVDP}" \
+  --build-arg go_version="%{go_version}" \
   --tag %{COMPONENT}:%{IMAGE_TAG} \
   %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT}/