Kubernetes update to 1.16.2
[ta/caas-kubernetes.git] / caas-kubernetes.spec
index b4b344d..0a0dc7c 100644 (file)
 
 %define COMPONENT kubernetes
 %define RPM_NAME caas-%{COMPONENT}
-%define RPM_MAJOR_VERSION 1.16.0
-%define RPM_MINOR_VERSION 3
+%define RPM_MAJOR_VERSION 1.16.2
+%define RPM_MINOR_VERSION 0
 %define IMAGE_TAG %{RPM_MAJOR_VERSION}-%{RPM_MINOR_VERSION}
 %define KUBERNETESPAUSE_VERSION 3.1
 
-%define go_version 1.12.9
+%define go_version 1.12.10
 %define ceph_version 12.2.5
 %define binary_build_dir %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/binary-save
 %define docker_build_dir %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build
@@ -160,6 +160,7 @@ ln -s %{_playbooks_path}/master_kube_proxy.yaml             %{_postconfig_path}/
 ln -s %{_playbooks_path}/master_kubelet.yaml                %{_postconfig_path}/
 ln -s %{_playbooks_path}/service_account_creation.yaml      %{_postconfig_path}/
 ln -s %{_playbooks_path}/service_account_distribution.yaml  %{_postconfig_path}/
+ln -s %{_playbooks_path}/set_nodes_label.yaml               %{_postconfig_path}/
 
 %postun
 if [ $1 -eq 0 ]; then
@@ -175,6 +176,7 @@ if [ $1 -eq 0 ]; then
   rm -f %{_postconfig_path}/master_kubelet.yaml
   rm -f %{_postconfig_path}/service_account_creation.yaml
   rm -f %{_postconfig_path}/service_account_distribution.yaml
+  rm -f %{_postconfig_path}/set_nodes_label.yaml
 fi
 
 %clean