Simplify ElasticSearch to make it more robust
[ta/caas-logging.git] / SPECS / elasticsearch.spec
index 930bc02..08c8022 100644 (file)
 
 %define COMPONENT elasticsearch
 %define RPM_NAME caas-%{COMPONENT}
-%define RPM_MAJOR_VERSION 7.2.0
+%define RPM_MAJOR_VERSION 7.4.0
 %define RPM_MINOR_VERSION 0
 %define IMAGE_TAG %{RPM_MAJOR_VERSION}-%{RPM_MINOR_VERSION}
+%define centos_build 191001
 
 Name:           %{RPM_NAME}
 Version:        %{RPM_MAJOR_VERSION}
@@ -24,12 +25,12 @@ Release:        %{RPM_MINOR_VERSION}%{?dist}
 Summary:        Containers as a Service Elasticsearch component
 License:        %{_platform_license} and GNU General Public License v2.0 only and GNU Lesser General Public License v2.1 only and MIT license and BSD and Apache-2.0
 URL:            https://github.com/elastic/elasticsearch
-BuildArch:      x86_64
+BuildArch:      %{_arch}
 Vendor:         %{_platform_vendor} and elastic/elasticsearch unmodified
 Source0:        %{name}-%{version}.tar.gz
 
 Requires: docker-ce >= 18.09.2, rsync
-BuildRequires: docker-ce >= 18.09.2, xz
+BuildRequires: docker-ce >= 18.09.2, xz, wget
 
 %description
 This RPM contains the Elasticsearch container image for CaaS subsystem.
@@ -38,6 +39,7 @@ This RPM contains the Elasticsearch container image for CaaS subsystem.
 %autosetup
 
 %build
+wget --progress=dot:giga http://artifacts.ci.centos.org/sig-cloudinstance/centos-7-%{centos_build}/%{_arch}/centos-7-%{_arch}-docker.tar.xz -O %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT}/centos-7-docker.tar.xz
 docker build \
   --network=host \
   --no-cache \