Go updated to 1.12.9
[ta/caas-metrics.git] / SPECS / caas-custom_metrics.spec
index 7ee14f4..98382e0 100644 (file)
@@ -15,8 +15,9 @@
 %define COMPONENT custom_metrics
 %define RPM_NAME caas-%{COMPONENT}
 %define RPM_MAJOR_VERSION 0.5.0
-%define RPM_MINOR_VERSION 1
-%define DEPENDENCY_MANAGER_VERSION 0.5.0
+%define RPM_MINOR_VERSION 2
+%define go_version 1.12.9
+%define DEP_MAN_VERSION 0.5.0
 %define IMAGE_TAG %{RPM_MAJOR_VERSION}-%{RPM_MINOR_VERSION}
 
 Name:           %{RPM_NAME}
@@ -49,7 +50,8 @@ docker build \
   --build-arg http_proxy="${http_proxy}" \
   --build-arg https_proxy="${https_proxy}" \
   --build-arg no_proxy="${no_proxy}" \
-  --build-arg CUSTOM_METRICS="%{RPM_MAJOR_VERSION}" \
+  --build-arg CUSTOM_METRICS_VERSION="%{RPM_MAJOR_VERSION}" \
+  --build-arg go_version="%{go_version}" \
   --tag %{COMPONENT}:%{IMAGE_TAG} \
   %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT}/