Update versions
[ta/caas-metrics.git] / SPECS / caas-prometheus.spec
index d8ed79f..4a0a3be 100644 (file)
@@ -14,9 +14,9 @@
 
 %define COMPONENT prometheus
 %define RPM_NAME caas-%{COMPONENT}
-%define RPM_MAJOR_VERSION 2.9.2
-%define RPM_MINOR_VERSION 1
-%define GO_VERSION 1.12.1
+%define RPM_MAJOR_VERSION 2.13.1
+%define RPM_MINOR_VERSION 0
+%define go_version 1.13.1
 %define IMAGE_TAG %{RPM_MAJOR_VERSION}-%{RPM_MINOR_VERSION}
 
 Name:           %{RPM_NAME}
@@ -25,7 +25,7 @@ Release:        %{RPM_MINOR_VERSION}%{?dist}
 Summary:        Containers as a Service Prometheus component
 License:        %{_platform_license} and BSD and Apache License and MIT license and Mozilla Public License and Lesser General Public License and GNU General Public License v2.0 only
 URL:            https://github.com/prometheus/prometheus
-BuildArch:      x86_64
+BuildArch:      %{_arch}
 Vendor:         %{_platform_vendor} and prometheus/prometheus unmodified
 Source0:        %{name}-%{version}.tar.gz
 
@@ -49,8 +49,8 @@ docker build \
   --build-arg http_proxy="${http_proxy}" \
   --build-arg https_proxy="${https_proxy}" \
   --build-arg no_proxy="${no_proxy}" \
-  --build-arg PROMETHEUS="%{RPM_MAJOR_VERSION}" \
-  --build-arg GO_REQUIRED="%{GO_VERSION}" \
+  --build-arg PROMETHEUS_VERSION="%{RPM_MAJOR_VERSION}" \
+  --build-arg go_version="%{go_version}" \
   --tag %{COMPONENT}:%{IMAGE_TAG} \
   %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT}/