AArch64 support
[ta/caas-registry.git] / SPECS / registry.spec
index e3ec502..56a414c 100644 (file)
 %define COMPONENT registry
 %define RPM_NAME caas-%{COMPONENT}
 %define RPM_MAJOR_VERSION 2.7.1
-%define RPM_MINOR_VERSION 1
+%define RPM_MINOR_VERSION 10
 %define IMAGE_TAG %{RPM_MAJOR_VERSION}-%{RPM_MINOR_VERSION}
+%define go_version 1.12.10
+
 Name:           %{RPM_NAME}
 Version:        %{RPM_MAJOR_VERSION}
 Release:        %{RPM_MINOR_VERSION}%{?dist}
 Summary:        Containers as a Service Registry component
 License:        %{_platform_license} and Apache License and GNU Lesser General Public License v3.0 only and BSD 3-clause New or Revised License and MIT License and Common Development and Distribution License and BSD and GNU General Public License v2.0 only
 URL:            https://github.com/docker/distribution
-BuildArch:      x86_64
+BuildArch:      %{_arch}
 Vendor:         %{_platform_vendor} and docker/distribution unmodified
 Source0:        %{name}-%{version}.tar.gz
 
@@ -50,6 +52,7 @@ docker build \
   --build-arg https_proxy="${https_proxy}" \
   --build-arg no_proxy="${no_proxy}" \
   --build-arg REGISTRY="%{version}" \
+  --build-arg go_version="%{go_version}" \
   --tag %{COMPONENT}:%{IMAGE_TAG} \
   %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT}/
 
@@ -96,4 +99,3 @@ fi
 
 %clean
 rm -rf ${buildroot}
-