Added seed code for caas-security.
[ta/caas-security.git] / rpmbuild.spec
diff --git a/rpmbuild.spec b/rpmbuild.spec
new file mode 100644 (file)
index 0000000..ff5b344
--- /dev/null
@@ -0,0 +1,70 @@
+# Copyright 2019 Nokia
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#     http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+%define COMPONENT security
+%define RPM_NAME caas-%{COMPONENT}
+%define RPM_MAJOR_VERSION 1.0.0
+%define RPM_MINOR_VERSION 1
+%define RBAC_MANIFEST_DIR /var/lib/caas/rbac_manifests/
+
+Name:           %{RPM_NAME}
+Version:        %{RPM_MAJOR_VERSION}
+Release:        %{RPM_MINOR_VERSION}%{?dist}
+Summary:        Containers as a Service security related playbooks + manifests
+License:        %{_platform_license}
+BuildArch:      x86_64
+Vendor:         %{_platform_vendor}
+Source0:        %{name}-%{version}.tar.gz
+
+%description
+This rpm contains the necessary security related playbooks + manifests for the caas subsystem.
+
+%prep
+%autosetup
+
+%build
+
+%install
+mkdir -p %{buildroot}/%{RBAC_MANIFEST_DIR}/
+rsync -av rbac_manifests/* %{buildroot}/%{RBAC_MANIFEST_DIR}/
+
+mkdir -p %{buildroot}/%{_playbooks_path}/
+rsync -av ansible/playbooks/* %{buildroot}/%{_playbooks_path}/
+
+mkdir -p %{buildroot}/%{_roles_path}/
+rsync -av ansible/roles/* %{buildroot}/%{_roles_path}/
+
+%files
+%{RBAC_MANIFEST_DIR}/*
+%{_playbooks_path}/*
+%{_roles_path}/*
+
+
+%preun
+
+%post
+mkdir -p %{_postconfig_path}/
+ln -sf %{_playbooks_path}/rbac.yaml     %{_postconfig_path}
+ln -sf %{_playbooks_path}/security.yaml %{_postconfig_path}
+
+
+%postun
+if [ $1 -eq 0 ]; then
+    rm -f %{_postconfig_path}/rbac.yaml
+    rm -f %{_postconfig_path}/security.yaml
+fi
+
+
+%clean
+rm -rf ${buildroot}