Add cloudtaf framework
[ta/cloudtaf.git] / libraries / setup.py
diff --git a/libraries/setup.py b/libraries/setup.py
new file mode 100644 (file)
index 0000000..3590d58
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 2019 Nokia
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#     http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+from setuptools import (
+    setup,
+    find_packages)
+
+
+setup(
+    name='cloudtaflibs',
+    install_requires=['crl.remotesession'],
+    entry_points={'pytest11': [
+        'pytestremotesession = pytestremotesession.fixtures']},
+    include_package_data=True,
+    packages=find_packages())