f921026039e66ce861d449d4dc3b86256ceae219
[ta/remote-installer.git] / remote-installer.spec
1 # Copyright 2019 Nokia
2 #
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 Name:           remote-installer
16 Version:        %{_version}
17 Release:        2%{?dist}
18 Summary:        Contains components for the remote-installer
19 Group:          %{_platform_group}
20 License:        %{_platform_licence}
21 Source0:        %{name}-%{version}.tar.gz
22 Vendor:         %{_platform_vendor}
23 BuildArch:      %{_arch}
24
25 # BuildRequires:  docker
26
27 %description
28 Contains components for the remote-installer
29
30 %prep
31
32 %build
33 BASEIMAGE_TAG='centos:7.6.1810'
34
35 # For aarch64 use the closest available upstream version
36 if [ "%{_arch}" = "aarch64" ]; then
37     BASEIMAGE_TAG='centos@sha256:df89b0a0b42916b5b31b334fd52d3e396c226ad97dfe772848bdd6b00fb42bf0'
38 fi
39
40 scripts/build.sh -t "${BASEIMAGE_TAG}"
41
42 # Here hould be some registry but it should be handled by a Jenkis job
43 docker image save remote-installer >remote-installer-image.tar
44
45 %files