Initial version
[ta/remote-installer.git] / src / setup.py
diff --git a/src/setup.py b/src/setup.py
new file mode 100644 (file)
index 0000000..00a05ae
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 2019 Nokia
+
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#     http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+from setuptools import setup, find_packages
+setup(
+    name='remoteinstaller',
+    version='1.0',
+    license='Apache-2.0',
+    author='',
+    author_email='',
+    namespace_packages=['remoteinstaller'],
+    packages=find_packages(),
+    include_package_data=True,
+    description='Remote installer',
+    zip_safe=False,
+    scripts = [
+        'scripts/patchiso.sh'
+    ]
+    )