Seed code for yarf
[ta/yarf.git] / src / setup.py
diff --git a/src/setup.py b/src/setup.py
new file mode 100644 (file)
index 0000000..570e7fd
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 2019 Nokia
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#     http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+from setuptools import setup, find_packages
+setup(
+    name='yarf',
+    version='1.0',
+    license='Commercial',
+    author='Janne Suominen',
+    author_email='janne.suominen@nokia.com',
+    packages=find_packages(),
+    include_package_data=True,
+    url='https://gitlab.fp.nsn-rdnet.net/jannsuom/restfulframework',
+    description='Yet Another Restful Framework',
+    install_requires=['flask', 'flask-restful'],
+    entry_points={
+        'console_scripts': [
+            'restapi = yarf.app:main',
+        ],
+    },
+    zip_safe=False,
+    )