Source changed.
[ta/access-management.git] / config-encoder-macros.spec
1 # Copyright 2019 Nokia
2
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 %global sha 624ed05b65743a82bcfdef525176e6cfef5c71ee
16
17 Name:           config-encoder-macros
18 Version:        master.624ed05
19 Release:        1%{?dist}
20 Summary:        Helper macros for encoding config files
21 License:        MIT
22 URL:            https://github.com/picotrading/config-encoder-macros
23 Source0:        https://github.com/picotrading/%{name}/archive/%{sha}.zip
24 Vendor:         Jiri Tyr
25 BuildArch:      noarch
26
27 %define PKG_BASE_DIR /opt/config-encoder-macros
28
29 %description
30 Set of Jinja2 and ERB macros which help to encode Python and Ruby data structure into a different file format
31
32 %prep
33 %autosetup -n %{name}-%{sha} -p 1
34
35 %build
36
37 %install
38 mkdir -p %{buildroot}/%{PKG_BASE_DIR}
39 cp -r * %{buildroot}/%{PKG_BASE_DIR}/
40
41 %files
42 %license LICENSE.md
43 %defattr(0755,root,root)
44 %{PKG_BASE_DIR}
45
46 %clean
47 rm -rf %{buildroot}