Added seed code for access-management.
[ta/access-management.git] / config-encoder-macros.spec
1 # Copyright 2019 Nokia
2
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 Name:           config-encoder-macros
16 Version:        master.624ed05
17 Release:        1%{?dist}
18 Summary:        Helper macros for encoding config files
19 License:        MIT
20 URL:            https://github.com/picotrading/config-encoder-macros
21 Source0:        http://purkki.dynamic.nsn-net.net/sources/github/picotrading/config-encoder-macros/config-encoder-macros-master.624ed05.tgz
22 Vendor:         Jiri Tyr
23 BuildArch:      noarch
24
25 %define PKG_BASE_DIR /opt/config-encoder-macros
26
27 %description
28 Set of Jinja2 and ERB macros which help to encode Python and Ruby data structure into a different file format
29
30 %prep
31 %autosetup
32
33 %build
34
35 %install
36 mkdir -p %{buildroot}/%{PKG_BASE_DIR}
37 cp -r * %{buildroot}/%{PKG_BASE_DIR}/
38
39 %files
40 %license LICENSE.md
41 %defattr(0755,root,root)
42 %{PKG_BASE_DIR}
43
44 %clean
45 rm -rf %{buildroot}