Add seed code for ansible-role-ntp
[ta/ansible-role-ntp.git] / ansible-role-ntp.spec
1 # Copyright 2019 Nokia
2 #
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 Name:       ansible-role-ntp
16 Version:    0.4.0.2.g4fc673c
17 Release:    1%{?dist}
18 Summary:    This role enables users to install and configure ntp on their hosts.
19
20 Vendor:     %{_platform_vendor} and Benno Joy, RenĂ© Moser modified
21 License:    %{_platform_licence} and BSD
22 URL:        https://github.com/resmo/ansible-role-ntp
23 Source0:    https://github.com/resmo/%{name}/archive/%{sha}.zip
24 Patch0:     0001-initial.patch
25
26 BuildArch:      noarch
27 BuildRequires:  python python-setuptools
28 Requires:   ansible => 1.4
29
30 %global sha 4fc673cfdf6cb3704a8be10cd10728a21be8f1bb
31
32 %description
33
34 %prep
35 %autosetup -n %{name}-%{sha} -p 1
36
37 %install
38 mkdir -p %{buildroot}/etc/ansible/roles/ntp
39
40 rsync -av --exclude ansible-role-ntp.spec \
41           --exclude .travis.yml \
42           --exclude .gitignore \
43           --exclude README.md \
44           --exclude *tests* \
45           --exclude .git \
46           --exclude .gitreview \
47           . %{buildroot}/etc/ansible/roles/ntp/
48 %files
49 %defattr(0755,root,root)
50 /etc/ansible/roles/ntp/