Go version update to 1.12.9
[ta/caas-cpupooler.git] / rpmbuild.spec
1 # Copyright 2019 Nokia
2 #
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 %define COMPONENT cpupooler
16 %define COMPONENT_PART process-starter
17 %define RPM_NAME caas-%{COMPONENT}
18 %define RPM_MAJOR_VERSION 0.3.0
19 %define RPM_MINOR_VERSION 4
20 %define go_version 1.12.9
21 %define CPUPOOLER_VERSION d94704e4b2f9f91ee712c6385038413fb7aa064a
22 %define DEP_MAN_VERSION 0.5.0
23 %define IMAGE_TAG %{RPM_MAJOR_VERSION}-%{RPM_MINOR_VERSION}
24 %define PROCESS_STARTER_INSTALL_PATH /opt/bin/
25
26 Name:           %{RPM_NAME}
27 Version:        %{RPM_MAJOR_VERSION}
28 Release:        %{RPM_MINOR_VERSION}%{?dist}
29 Summary:        Containers as a Service cpu-pooler component
30 License:        %{_platform_license} and BSD 3-Clause License
31 URL:            https://github.com/nokia/CPU-Pooler
32 BuildArch:      x86_64
33 Vendor:         %{_platform_vendor} and Nokia
34 Source0:        %{name}-%{version}.tar.gz
35
36 Requires: docker-ce >= 18.09.2, rsync
37 BuildRequires: docker-ce-cli >= 18.09.2, xz
38
39 # I was able to pack an executable via this.
40 # more info at https://fedoraproject.org/wiki/Packaging:Debuginfo
41 %global debug_package %{nil}
42
43 %description
44 This RPM contains the cpu-pooler container image, process-starter binary and related deployment artifacts for the CaaS subsystem.
45
46 %prep
47 %autosetup
48
49 %build
50 # build the process-starter binary inside a builder conatiner
51 docker build \
52   --network=host \
53   --no-cache \
54   --force-rm \
55   --build-arg HTTP_PROXY="${http_proxy}" \
56   --build-arg HTTPS_PROXY="${https_proxy}" \
57   --build-arg NO_PROXY="${no_proxy}" \
58   --build-arg http_proxy="${http_proxy}" \
59   --build-arg https_proxy="${https_proxy}" \
60   --build-arg no_proxy="${no_proxy}" \
61   --build-arg go_version="%{go_version}" \
62   --build-arg DEP_MAN_VERSION="%{DEP_MAN_VERSION}" \
63   --build-arg CPUPOOLER_VERSION="%{CPUPOOLER_VERSION}" \
64   --tag %{COMPONENT_PART}:builder \
65   %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT_PART}/
66
67 # create a directory for process-starter binary
68 mkdir -p %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/results
69
70 # run the builder conatiner for process-starter binary
71 docker run \
72   -id \
73   --rm \
74   --network=host \
75   --privileged \
76   -e HTTP_PROXY="${http_proxy}" \
77   -e HTTPS_PROXY="${https_proxy}" \
78   -e NO_PROXY="${no_proxy}" \
79   -e http_proxy="${http_proxy}" \
80   -e https_proxy="${https_proxy}" \
81   -e no_proxy="${no_proxy}" \
82   --entrypoint=/bin/sh \
83   %{COMPONENT_PART}:builder
84
85 # get the process-starter binary
86 docker cp $(docker ps | grep "%{COMPONENT_PART}:builder" | awk -F' ' '{ print $1 }'):/process-starter %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/results/
87
88 # rm container
89 for container_ran in $(docker ps -a | grep "%{COMPONENT_PART}:builder" | awk -F' ' '{ print $1 }')
90 do
91     docker rm -f $container_ran
92 done
93
94 # remove docker image
95 docker rmi -f %{COMPONENT_PART}:builder
96
97 # build the cpu pooler
98 docker build \
99   --network=host \
100   --no-cache \
101   --force-rm \
102   --build-arg HTTP_PROXY="${http_proxy}" \
103   --build-arg HTTPS_PROXY="${https_proxy}" \
104   --build-arg NO_PROXY="${no_proxy}" \
105   --build-arg http_proxy="${http_proxy}" \
106   --build-arg https_proxy="${https_proxy}" \
107   --build-arg no_proxy="${no_proxy}" \
108   --build-arg DEP_MAN_VERSION="%{DEP_MAN_VERSION}" \
109   --build-arg CPUPOOLER_VERSION="%{CPUPOOLER_VERSION}" \
110   --build-arg go_version="%{go_version}" \
111   --tag %{COMPONENT}:%{IMAGE_TAG} \
112   %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT}/
113
114 # create a save folder
115 mkdir -p %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/
116
117 # save the cpu poooler container
118 docker save %{COMPONENT}:%{IMAGE_TAG} | xz -z -T2 > %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/%{COMPONENT}:%{IMAGE_TAG}.tar
119
120 # remove docker image
121 docker rmi -f %{COMPONENT}:%{IMAGE_TAG}
122
123 %install
124 mkdir -p %{buildroot}/%{_caas_container_tar_path}/
125 rsync -av %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/%{COMPONENT}:%{IMAGE_TAG}.tar %{buildroot}/%{_caas_container_tar_path}/
126
127 mkdir -p %{buildroot}%{PROCESS_STARTER_INSTALL_PATH}
128 rsync -av %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/results/process-starter %{buildroot}/%{PROCESS_STARTER_INSTALL_PATH}/
129
130 mkdir -p %{buildroot}/%{_playbooks_path}/
131 rsync -av ansible/playbooks/cpupooler.yaml %{buildroot}/%{_playbooks_path}/
132
133 mkdir -p %{buildroot}/%{_roles_path}/
134 rsync -av ansible/roles/cpupooler %{buildroot}/%{_roles_path}/
135
136 %files
137 %{_caas_container_tar_path}/%{COMPONENT}:%{IMAGE_TAG}.tar
138 %{PROCESS_STARTER_INSTALL_PATH}/process-starter
139 %{_playbooks_path}/cpupooler.yaml
140 %{_roles_path}/cpupooler
141
142 %preun
143
144 %post
145 mkdir -p %{_postconfig_path}/
146 ln -sf %{_playbooks_path}/cpupooler.yaml %{_postconfig_path}/
147
148 %postun
149 if [ $1 -eq 0 ]; then
150     rm -f %{_postconfig_path}/cpupooler.yaml
151 fi
152
153 %clean
154 rm -rf ${buildroot}