CaaS DANM update to 4.1.0
[ta/caas-danm.git] / SPECS / caas-sriovdp.spec
1 # Copyright 2019 Nokia
2 #
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 %define COMPONENT sriovdp
16 %define RPM_NAME caas-%{COMPONENT}
17 %define RPM_MAJOR_VERSION 3.0.0
18 %define RPM_MINOR_VERSION 1
19 %define IMAGE_TAG %{RPM_MAJOR_VERSION}-%{RPM_MINOR_VERSION}
20 %define go_version 1.12.10
21 %define SRIOVDP_HASH a015e56ae715e2b6dae15e42827e4e8f43eeceac
22
23 Name:           %{RPM_NAME}
24 Version:        %{RPM_MAJOR_VERSION}
25 Release:        %{RPM_MINOR_VERSION}%{?dist}
26 Summary:        Containers as a Service sriov network device plugin component
27 License:        %{_platform_license} and Apache License 2.0
28 URL:            https://github.com/intel/sriov-network-device-plugin/
29 BuildArch:      x86_64
30 Vendor:         %{_platform_vendor} and intel/sriov-network-device-plugin unmodified
31 Source0:        %{name}-%{version}.tar.gz
32
33 Requires: docker-ce >= 18.09.2, rsync
34 BuildRequires: docker-ce-cli >= 18.09.2, xz
35
36 %description
37 This RPM contains the sriov network device plugin container for CaaS subsystem.
38
39 %prep
40 %autosetup
41
42 %build
43 docker build \
44   --network=host \
45   --no-cache \
46   --force-rm \
47   --build-arg HTTP_PROXY="${http_proxy}" \
48   --build-arg HTTPS_PROXY="${https_proxy}" \
49   --build-arg NO_PROXY="${no_proxy}" \
50   --build-arg http_proxy="${http_proxy}" \
51   --build-arg https_proxy="${https_proxy}" \
52   --build-arg no_proxy="${no_proxy}" \
53   --build-arg SRIOVDP="%{RPM_MAJOR_VERSION}" \
54   --build-arg SRIOVDP_HASH="%{SRIOVDP_HASH}" \
55   --build-arg go_version="%{go_version}" \
56   --tag %{COMPONENT}:%{IMAGE_TAG} \
57   %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT}/
58
59 mkdir -p %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/
60
61 docker save %{COMPONENT}:%{IMAGE_TAG} | xz -z -T2 > %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/%{COMPONENT}:%{IMAGE_TAG}.tar
62
63 docker rmi -f %{COMPONENT}:%{IMAGE_TAG}
64
65 %install
66 mkdir -p %{buildroot}/%{_caas_container_tar_path}/
67 rsync -av %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/%{COMPONENT}:%{IMAGE_TAG}.tar %{buildroot}/%{_caas_container_tar_path}/
68
69 %files
70 %{_caas_container_tar_path}/%{COMPONENT}:%{IMAGE_TAG}.tar
71
72 %preun
73
74 %post
75
76 %postun
77
78 %clean
79 rm -rf ${buildroot}