83415a28a5472461079231c9cee8b78fa12159c5
[ta/caas-helm.git] / SPECS / caas-helm.spec
1 # Copyright 2019 Nokia
2 #
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 %define COMPONENT helm
16 %define RPM_NAME caas-%{COMPONENT}
17 %define RPM_MAJOR_VERSION 2.14.1
18 %define RPM_MINOR_VERSION 0
19 %define IMAGE_TAG %{RPM_MAJOR_VERSION}-%{RPM_MINOR_VERSION}
20 %define go_version 1.11.5
21 %define cni_plugins_version 0.7.0
22 %define binary_build_dir %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/binary-save
23 %define docker_build_dir %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build
24 %define docker_save_dir %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save
25 %define built_binaries_dir /binary-save
26
27 Name:           %{RPM_NAME}
28 Version:        %{RPM_MAJOR_VERSION}
29 Release:        %{RPM_MINOR_VERSION}%{?dist}
30 Summary:        Containers as a Service %{COMPONENT} component
31 License:        %{_platform_licence} and MIT license and BSD and Apache License and Lesser General Public License
32 BuildArch:      x86_64
33 Vendor:         %{_platform_vendor} and helm/helm unmodified
34 Source0:        %{name}-%{version}.tar.gz
35
36 Requires: docker-ce >= 18.09.2, rsync
37 BuildRequires: docker-ce-cli >= 18.09.2, rsync, xz
38
39 %description
40 This rpm contains the %{COMPONENT} container for CaaS subsystem.
41 This container contains the %{COMPONENT} service.
42
43 %prep
44 %autosetup
45
46 %build
47 # Build Helm binaries
48 docker build \
49   --network=host \
50   --no-cache \
51   --force-rm \
52   --build-arg HTTP_PROXY="${http_proxy}" \
53   --build-arg HTTPS_PROXY="${https_proxy}" \
54   --build-arg NO_PROXY="${no_proxy}" \
55   --build-arg http_proxy="${http_proxy}" \
56   --build-arg https_proxy="${https_proxy}" \
57   --build-arg no_proxy="${no_proxy}" \
58   --build-arg HELM_VERSION="%{version}" \
59   --build-arg go_version="%{go_version}" \
60   --build-arg binaries="%{built_binaries_dir}" \
61   --tag helm-builder:%{IMAGE_TAG} \
62   %{docker_build_dir}/helm-builder
63
64 mkdir -p %{binary_build_dir}
65 builder_container=$(docker run -id --rm --network=none --entrypoint=/bin/sh helm-builder:%{IMAGE_TAG})
66 docker cp ${builder_container}:%{built_binaries_dir}/helm   %{binary_build_dir}/
67 docker cp ${builder_container}:%{built_binaries_dir}/tiller %{binary_build_dir}/
68 docker rm -f ${builder_container}
69 docker rmi helm-builder:%{IMAGE_TAG}
70
71 # Build tiller container image
72 rsync -av %{binary_build_dir}/* %{docker_build_dir}/tiller/
73 docker build \
74   --network=host \
75   --no-cache \
76   --force-rm \
77   --build-arg HTTP_PROXY="${http_proxy}" \
78   --build-arg HTTPS_PROXY="${https_proxy}" \
79   --build-arg NO_PROXY="${no_proxy}" \
80   --build-arg http_proxy="${http_proxy}" \
81   --build-arg https_proxy="${https_proxy}" \
82   --build-arg no_proxy="${no_proxy}" \
83   --tag tiller:%{IMAGE_TAG} \
84   %{docker_build_dir}/tiller
85 mkdir -p %{docker_save_dir}/
86 docker save tiller:%{IMAGE_TAG} | xz -z -T2 > "%{docker_save_dir}/tiller:%{IMAGE_TAG}.tar"
87 docker rmi tiller:%{IMAGE_TAG}
88
89 %install
90 mkdir -p %{buildroot}/%{_caas_container_tar_path}
91 rsync -av %{docker_save_dir}/* %{buildroot}/%{_caas_container_tar_path}/
92
93 mkdir -p %{buildroot}/%{_roles_path}
94 rsync -av ansible/roles/helm %{buildroot}/%{_roles_path}/
95
96 install -D ansible/playbooks/helm.yaml %{buildroot}/%{_playbooks_path}/helm.yaml
97
98 install -D -m 0755 %{binary_build_dir}/helm %{buildroot}/usr/bin/helm
99
100 %files
101 %{_caas_container_tar_path}/tiller:%{IMAGE_TAG}.tar
102 %{_roles_path}/helm
103 %{_playbooks_path}/helm.yaml
104 /usr/bin/helm
105
106 %preun
107
108 %post
109 mkdir -p %{_postconfig_path}
110 ln -s %{_playbooks_path}/helm.yaml %{_postconfig_path}/
111
112 %postun
113 if [ $1 -eq 0 ]; then
114   rm -f %{_postconfig_path}/helm.yaml
115 fi
116
117 %clean
118 rm -rf ${buildroot}