Kubedns update
[ta/caas-kubedns.git] / rpmbuild.spec
1 # Copyright 2019 Nokia
2 #
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 %define COMPONENT kubedns
16 %define RPM_NAME caas-%{COMPONENT}
17 %define RPM_MAJOR_VERSION 1.15.4
18 %define RPM_MINOR_VERSION 0
19 %define IMAGE_TAG %{RPM_MAJOR_VERSION}-%{RPM_MINOR_VERSION}
20
21 Name:           %{RPM_NAME}
22 Version:        %{RPM_MAJOR_VERSION}
23 Release:        %{RPM_MINOR_VERSION}%{?dist}
24 Summary:        Containers as a Service Kube DNS component
25 License:        %{_platform_license} and Apache License and GNU Lesser General Public License v3.0 only and BSD 3-clause New or Revised License and MIT License and Common Development and Distribution License and BSD and GNU General Public License v2.0 only
26 URL:            https://github.com/kubernetes/dns
27 BuildArch:      x86_64
28 Vendor:         %{_platform_vendor} and Kubernetes DNS service unmodified
29 Source0:        %{name}-%{version}.tar.gz
30
31 Requires: docker-ce >= 18.09.2, rsync
32 BuildRequires: docker-ce-cli >= 18.09.2, xz
33
34 %description
35 This RPM contains the kubedns container image, and related deployment artifacts for the CaaS subsystem.
36
37 %prep
38 %autosetup
39
40 %build
41 # Building the container
42 docker build \
43   --network=host \
44   --no-cache \
45   --force-rm \
46   --build-arg HTTP_PROXY="${http_proxy}" \
47   --build-arg HTTPS_PROXY="${https_proxy}" \
48   --build-arg NO_PROXY="${no_proxy}" \
49   --build-arg http_proxy="${http_proxy}" \
50   --build-arg https_proxy="${https_proxy}" \
51   --build-arg no_proxy="${no_proxy}" \
52   --build-arg KUBEDNS="%{RPM_MAJOR_VERSION}" \
53   --tag %{COMPONENT}:%{IMAGE_TAG} \
54   %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT}/
55
56 # Creating a new folder for the container tar file
57 mkdir -p %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/
58
59 # Save the container
60 docker save %{COMPONENT}:%{IMAGE_TAG} | xz -z -T2 > %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/%{COMPONENT}:%{IMAGE_TAG}.tar
61
62 # Remove docker image
63 docker rmi -f %{COMPONENT}:%{IMAGE_TAG}
64
65 %install
66 mkdir -p %{buildroot}/%{_caas_container_tar_path}/
67 rsync -av %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/%{COMPONENT}:%{IMAGE_TAG}.tar %{buildroot}/%{_caas_container_tar_path}/
68
69 mkdir -p %{buildroot}/%{_playbooks_path}/
70 rsync -av ansible/playbooks/kubedns.yaml %{buildroot}/%{_playbooks_path}/
71
72 mkdir -p %{buildroot}/%{_roles_path}/
73 rsync -av ansible/roles/kubedns %{buildroot}/%{_roles_path}/
74
75 %files
76 %{_caas_container_tar_path}/%{COMPONENT}:%{IMAGE_TAG}.tar
77 %{_playbooks_path}/kubedns.yaml
78 %{_roles_path}/kubedns
79
80 %preun
81
82 %post
83 mkdir -p %{_postconfig_path}/
84 ln -sf %{_playbooks_path}/kubedns.yaml %{_postconfig_path}/
85
86 %postun
87 if [ $1 -eq 0 ]; then
88     rm -f %{_postconfig_path}/kubedns.yaml
89 fi
90
91 %clean
92 rm -rf ${buildroot}