registry + swift CN added
[ta/caas-registry.git] / SPECS / swift.spec
1 # Copyright 2019 Nokia
2 #
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 %define COMPONENT swift
16 %define RPM_NAME caas-%{COMPONENT}
17 %define RPM_MAJOR_VERSION 2.21.0
18 %define RPM_MINOR_VERSION 6
19 %define IMAGE_TAG %{RPM_MAJOR_VERSION}-%{RPM_MINOR_VERSION}
20 Name:           %{RPM_NAME}
21 Version:        %{RPM_MAJOR_VERSION}
22 Release:        %{RPM_MINOR_VERSION}%{?dist}
23 Summary:        Containers as a Service Swift component
24 License:        %{_platform_license} and Apache License and GNU Lesser General Public License v3.0 only and BSD 3-clause New or Revised License and MIT License and Common Development and Distribution License and BSD and GNU General Public License v2.0 only
25 URL:            https://github.com/openstack/swift
26 BuildArch:      x86_64
27 Vendor:         %{_platform_vendor} and openstack/swift unmodified
28 Source0:        %{name}-%{version}.tar.gz
29
30 Requires: docker-ce >= 18.09.2, rsync
31 BuildRequires: docker-ce-cli >= 18.09.2, xz
32
33 %description
34 This rpm contains the swift container and ansible for caas subsystem.
35 This container contains the swift service.
36
37 %prep
38 %autosetup
39
40 %build
41 # Building the container
42 docker build \
43   --network=host \
44   --no-cache \
45   --force-rm \
46   --build-arg HTTP_PROXY="${http_proxy}" \
47   --build-arg HTTPS_PROXY="${https_proxy}" \
48   --build-arg NO_PROXY="${no_proxy}" \
49   --build-arg http_proxy="${http_proxy}" \
50   --build-arg https_proxy="${https_proxy}" \
51   --build-arg no_proxy="${no_proxy}" \
52   --build-arg SWIFT="%{version}" \
53   --tag %{COMPONENT}:%{IMAGE_TAG} \
54   %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build/%{COMPONENT}/
55
56 # Creating a new folder for the container tar file
57 mkdir -p %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/
58
59 # Save the container
60 docker save %{COMPONENT}:%{IMAGE_TAG} | xz -z -T2 > %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/%{COMPONENT}:%{IMAGE_TAG}.tar
61
62 # Remove container
63 docker rmi -f %{COMPONENT}:%{IMAGE_TAG}
64
65 %install
66 mkdir -p %{buildroot}/%{_caas_container_tar_path}/
67 rsync -av %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save/%{COMPONENT}:%{IMAGE_TAG}.tar %{buildroot}/%{_caas_container_tar_path}/
68
69 mkdir -p %{buildroot}/%{_playbooks_path}/
70 rsync -av ansible/playbooks/swift.yaml %{buildroot}/%{_playbooks_path}/
71
72 mkdir -p %{buildroot}/%{_roles_path}/
73 rsync -av ansible/roles/swift %{buildroot}/%{_roles_path}/
74
75
76 %files
77 %{_caas_container_tar_path}/%{COMPONENT}:%{IMAGE_TAG}.tar
78 %{_playbooks_path}/*
79 %{_roles_path}/*
80
81 %preun
82
83 %post
84 mkdir -p %{_postconfig_path}/
85 ln -sf %{_playbooks_path}/swift.yaml %{_postconfig_path}/
86
87 %postun
88 if [ $1 -eq 0 ]; then
89     rm -f %{_postconfig_path}/swift.yaml
90 fi
91
92 %clean
93 rm -rf ${buildroot}