Minor version bump.
[ta/caas-storage.git] / SPECS / storage_local_static_provisioner.spec
1 # Copyright 2019 Nokia
2 #
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 %define COMPONENT storage_local_static_provisioner
16 %define RPM_NAME caas-%{COMPONENT}
17 %define RPM_MAJOR_VERSION 2.3.3
18 %define RPM_MINOR_VERSION 1
19 %define go_version 1.12.9
20 %define IMAGE_TAG %{RPM_MAJOR_VERSION}-%{RPM_MINOR_VERSION}
21 %define docker_build_dir %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-build
22 %define docker_save_dir %{_builddir}/%{RPM_NAME}-%{RPM_MAJOR_VERSION}/docker-save
23
24 Name:           %{RPM_NAME}
25 Version:        %{RPM_MAJOR_VERSION}
26 Release:        %{RPM_MINOR_VERSION}%{?dist}
27 Summary:        Containers as a Service %{COMPONENT} component
28 License:        %{_platform_license} and GNU General Public License v2.0 only and MIT license and BSD 3-clause New or Revised License and MIT License and Curl License and BSD
29 URL:            https://github.com/kubernetes-sigs/sig-storage-local-static-provisioner
30 BuildArch:      %{_arch}
31 Vendor:         %{_platform_vendor} and kubernetes-sigs/sig-storage-local-static-provisioner unmodified
32 Source0:        %{name}-%{version}.tar.gz
33
34 Requires: docker-ce >= 18.09.2, rsync
35 BuildRequires: docker-ce-cli >= 18.09.2, xz
36
37 %description
38 This rpm contains the storage local static provisioner container for caas subsystem.
39
40 %prep
41 %autosetup
42
43 %build
44 docker build \
45   --network=host \
46   --no-cache \
47   --force-rm \
48   --build-arg HTTP_PROXY="${http_proxy}" \
49   --build-arg HTTPS_PROXY="${https_proxy}" \
50   --build-arg NO_PROXY="${no_proxy}" \
51   --build-arg http_proxy="${http_proxy}" \
52   --build-arg https_proxy="${https_proxy}" \
53   --build-arg no_proxy="${no_proxy}" \
54   --build-arg STORAGE_LOCAL_STATIC_PROVISIONER_VERSION="%{version}" \
55   --build-arg go_version="%{go_version}" \
56   --tag %{COMPONENT}:%{IMAGE_TAG} \
57   %{docker_build_dir}/%{COMPONENT}/
58 mkdir -p %{docker_save_dir}/
59 docker save %{COMPONENT}:%{IMAGE_TAG} | xz -z -T2 > %{docker_save_dir}/%{COMPONENT}:%{IMAGE_TAG}.tar
60 docker rmi %{COMPONENT}:%{IMAGE_TAG}
61
62 %install
63 mkdir -p %{buildroot}/%{_caas_container_tar_path}
64 rsync -av %{docker_save_dir}/%{COMPONENT}:%{IMAGE_TAG}.tar %{buildroot}/%{_caas_container_tar_path}/
65
66 mkdir -p %{buildroot}/%{_roles_path}
67 rsync -av ansible/roles/* %{buildroot}/%{_roles_path}/
68
69 install -D ansible/playbooks/kubernetes_storage.yaml %{buildroot}/%{_playbooks_path}/kubernetes_storage.yaml
70
71 %files
72 %{_caas_container_tar_path}/%{COMPONENT}:%{IMAGE_TAG}.tar
73 %{_roles_path}/kubernetes_storage
74 %{_playbooks_path}/kubernetes_storage.yaml
75
76 %preun
77
78 %post
79 mkdir -p %{_postconfig_path}
80 ln -s %{_playbooks_path}/kubernetes_storage.yaml %{_postconfig_path}/
81
82 %postun
83 if [ $1 -eq 0 ]; then
84   rm -f %{_postconfig_path}/kubernetes_storage.yaml
85 fi
86
87 %clean
88 rm -rf ${buildroot}
89