f74ff3517499f4855cd77e624a223d3c71f51acd
[ta/cm-plugins.git] / inventoryhandlers.spec
1 # Copyright 2019 Nokia
2 #
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #    http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 Name:       inventoryhandlers
16 Version:    %{_version}
17 Release:    1%{?dist}
18 Summary:    Inventory handlers
19 License:        %{_platform_licence}
20 Source0:        %{name}-%{version}.tar.gz
21 Vendor:         %{_platform_vendor}
22
23 BuildArch:      noarch
24
25 %define PKG_BASE_DIR /opt/cmframework/inventoryhandlers
26
27 %description
28 Inventory handlers
29
30
31 %prep
32 %autosetup
33
34 %build
35
36 %install
37 mkdir -p %{buildroot}/%{PKG_BASE_DIR}/
38 find inventoryhandlers -name '*.py' -exec cp {} %{buildroot}/%{PKG_BASE_DIR}/ \;
39
40 %files
41 %defattr(0755,root,root,0755)
42 %{PKG_BASE_DIR}/*.py*
43
44 %preun
45
46
47 %postun
48
49 %clean
50 rm -rf ${buildroot}
51