storageinventory: Refactor ceph key generation
[ta/cm-plugins.git] / validators.spec
1 # Copyright 2019 Nokia
2 #
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #    http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 Name:           validators
16 Version:        %{_version}
17 Release:        1%{?dist}
18 Summary:        Configuration validators
19 License:        %{_platform_licence}
20 Source0:        %{name}-%{version}.tar.gz
21 Vendor:         %{_platform_vendor}
22 BuildArch:      noarch
23 BuildRequires:  python
24
25 Requires: python-django, python-ipaddr
26
27 %define PKG_BASE_DIR /opt/cmframework/validators
28
29 %description
30 This RPM contains source code for configuration validators
31
32 %prep
33 %autosetup
34
35 %install
36 mkdir -p %{buildroot}/%{PKG_BASE_DIR}/
37 find validators/src -name '*.py' -exec cp {} %{buildroot}/%{PKG_BASE_DIR}/ \;
38
39 %files
40 %defattr(0755,root,root,0755)
41 %{PKG_BASE_DIR}/*.py*
42
43 %pre
44
45 %post
46
47 %preun
48
49 %postun
50
51 %clean
52 rm -rf %{buildroot}