Seed code for hostcli
[ta/hostcli.git] / hostcli.spec
1 # Copyright 2019 Nokia
2 #
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14 #
15
16 Name:       hostcli
17 Version:    %{_version}
18 Release:    1%{?dist}
19 Summary:    Contains code for the hostcli framework.
20 License:    %{_platform_licence}
21 Source0:    %{name}-%{version}.tar.gz
22 Vendor:     %{_platform_vendor}
23 BuildArch:  noarch
24
25 Requires: python-cliff python-pip python2-osc-lib python-openstackclient
26 BuildRequires: python
27 BuildRequires: python-setuptools
28
29
30 %description
31 This RPM contains source code for the hostcli framework.
32
33 %prep
34 %autosetup
35
36 %install
37 cd src && python setup.py install --root %{buildroot} --no-compile --install-purelib %{_python_site_packages_path} --install-scripts %{_platform_bin_path} && cd -
38
39
40 %files
41 %{_python_site_packages_path}/hostcli*
42 #%{_python_site_packages_path}/hostcli.*
43 %{_platform_bin_path}/hostcli
44
45 %pre
46
47 %post
48
49
50 %preun
51
52 %postun
53
54 %clean
55 rm -rf %{buildroot}
56
57 # TIPS:
58 # File /usr/lib/rpm/macros contains useful variables which can be used for example to define target directory for man page.