82e010e40922c0b7ed25c9ca9cda878848a1c5fb
[ta/hw-detector.git] / hw-detector.spec
1 # Copyright 2019 Nokia
2
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 Name:           hw-detector
16 Version:        %{_version}
17 Release:        1%{?dist}
18 Summary:        Hardware detector
19 Group:          Nokia
20 License:        %{_platform_licence}
21 Source0:        %{name}-%{version}.tar.gz
22 Vendor:         %{_platform_vendor}
23
24 Requires: python 
25 BuildRequires: python
26 BuildRequires: python-setuptools
27
28 %description
29 Hardware detector for different hardware types
30
31 %prep
32 %autosetup
33
34 %build
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 mkdir -p %{buildroot}/%{_python_site_packages_path}/hw_detector
39
40 cd src && python setup.py install --root %{buildroot} --no-compile --install-purelib %{_python_site_packages_path} --install-scripts /usr/local/bin && cd -
41
42 %files
43 %defattr(0755,root,root)
44 %{_python_site_packages_path}/hw_detector*
45
46 %pre
47
48 %post
49
50 %postun