Add hardware type for Ampere Hawk server
[ta/hw-detector.git] / hw-detector.spec
1 # Copyright 2019 Nokia
2
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 Name:           hw-detector
16 Version:        %{_version}
17 Release:        4%{?dist}
18 Summary:        Hardware detector
19 Group:          Nokia
20 License:        %{_platform_licence}
21 Source0:        %{name}-%{version}.tar.gz
22 BuildArch:      noarch
23 Vendor:         %{_platform_vendor}
24
25 Requires: python
26 BuildRequires: python
27 BuildRequires: python-setuptools
28
29 %description
30 Hardware detector for different hardware types
31
32 %prep
33 %autosetup
34
35 %build
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 mkdir -p %{buildroot}/%{_python_site_packages_path}/hw_detector
40
41 cd src && python setup.py install --root %{buildroot} --no-compile --install-purelib %{_python_site_packages_path} --install-scripts /usr/local/bin && cd -
42
43 %files
44 %defattr(0755,root,root)
45 %{_python_site_packages_path}/hw_detector*
46
47 %pre
48
49 %post
50
51 %postun