Initial commit
[ta/lockcli.git] / lockcli.spec
1 # Copyright 2019 Nokia
2
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 Name:       lockcli
16 Version:    %{_version}
17 Release:    1%{?dist}
18 Summary:    Contains code for the lock CLI
19 License:    %{_platform_licence}
20 Source0:    %{name}-%{version}.tar.gz
21 Vendor:     %{_platform_vendor}
22 BuildArch:  noarch
23
24 BuildRequires: python
25 BuildRequires: python-setuptools
26 Requires: python-etcd
27 Requires: etcd
28
29 %description
30 This RPM contains source code for the lock cli
31
32 %prep
33 %autosetup
34
35 %install
36 mkdir -p %{buildroot}/%{_python_site_packages_path}/lockcli/
37 set -e
38 cd src && python setup.py install --root %{buildroot} --no-compile --install-purelib %{_python_site_packages_path} --install-scripts %{_platform_bin_path} && cd -
39
40 %files
41 %defattr(0755,root,root,0755)
42 %{_python_site_packages_path}/lockcli*
43 %{_platform_bin_path}/lockcli
44
45 %pre
46
47 %post
48
49 %preun
50
51 %postun
52
53 %clean
54 rm -rf %{buildroot}