Initial commit
[ta/monitoring.git] / monitoring.spec
1 # Copyright 2019 Nokia
2
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 Name:       monitoring
16 Version:    %{_version}
17 Release:    1%{?dist}
18 Summary:    keepalived based node monitor and vip management
19 License:    %{_platform_licence}
20 Source0:    %{name}-%{version}.tar.gz
21 Vendor:     %{_platform_vendor}
22 BuildArch:  noarch
23 Requires: keepalived
24 BuildRequires: python
25 BuildRequires: python-setuptools
26
27 %description
28 This RPM contains code for the keepalived based monitoring
29
30 %prep
31 %autosetup
32
33 %build
34
35 %install
36 mkdir -p %{buildroot}/opt/monitoring/
37 cp src/*.sh %{buildroot}/opt/monitoring/
38 cp src/*.py %{buildroot}/opt/monitoring/
39
40 mkdir -p %{buildroot}/etc/monitoring/quorum-state-changed-actions
41 mkdir -p %{buildroot}/etc/monitoring/node-state-changed-actions
42
43 mkdir -p %{buildroot}/etc/monitoring/active-standby-services
44 cp active-standby-services/*.service %{buildroot}/etc/monitoring/active-standby-services/
45
46 cp active-standby-services/active-standby-controller.sh %{buildroot}/etc/monitoring/node-state-changed-actions/
47 cp active-standby-services/active-standby-monitor.sh %{buildroot}/opt/monitoring/
48
49 %files
50 /opt/monitoring/*
51 /etc/monitoring/quorum-state-changed-actions
52 /etc/monitoring/node-state-changed-actions
53 /etc/monitoring/node-state-changed-actions/*
54 /etc/monitoring/active-standby-services/*
55
56 %pre
57
58 %post
59 echo "monitoring succesfully installed"
60
61
62 %preun
63
64 %postun
65
66 %clean
67 rm -rf %{buildroot}