Upgrade os-net-config to version 10.4.1
[ta/os-net-config.git] / os-net-config.spec
1 Name:       os-net-config
2 Version:    10.4.1
3 Release:    0.20191003.14e46a5%{?dist}.1
4 Summary:    Host network configuration tool
5
6 License:    %{_platform_licence} and ASL 2.0
7 URL:        http://pypi.python.org/pypi/%{name}
8 Source0:    https://files.pythonhosted.org/packages/e6/4f/2e344cbe95e57c151c747df6367ace569697af7967b5b464d76ffcc3a4d8/%{name}-%{version}.tar.gz
9 Patch0:     0001-initial.patch
10 Vendor:     OpenStack Foundation and %{_platform_vendor} modified
11
12 BuildArch:      noarch
13 BuildRequires:  python-setuptools
14 BuildRequires:  python2-devel
15 BuildRequires:  python2-pbr >= 2.0.0
16 BuildRequires:  python-sphinx
17 BuildRequires:  python-oslo-sphinx
18
19 Requires:   python-anyjson >= 0.3.3
20 Requires:   python-eventlet >= 0.18.2
21 Requires:   python-oslo-concurrency >= 3.8.0
22 Requires:   python-oslo-config
23 Requires:   python-oslo-utils >= 3.20.0
24 Requires:   python-netaddr >= 0.7.13
25 Requires:   python-netifaces >= 0.10.4
26 Requires:   python-iso8601 >= 0.1.11
27 Requires:   python-six >= 1.9.0
28 Requires:   initscripts
29 Requires:   iproute
30 Requires:   ethtool
31 Requires:   openvswitch
32 Requires:   dhclient
33 Requires:   PyYAML >= 3.10
34 Requires:   python2-pbr >= 2.0.0
35 Requires:   python-jsonschema >= 2.0.0
36 Requires:   driverctl
37
38 %description
39 Host network configuration tool for OpenStack.
40
41 %prep
42
43 %autosetup -n %{name}-%{version} -p 1
44
45 %build
46 %{__python} setup.py build
47 %{__python} setup.py build_sphinx
48
49 %install
50 %{__python} setup.py install -O1 --skip-build --root %{buildroot}
51
52 %files
53 %doc README.rst
54 %doc LICENSE
55 %doc doc/build/html
56 %{_bindir}/os-net-config
57 %{_bindir}/os-net-config-sriov
58 %{python_sitelib}/os_net_config*