Add seed code for python-ilorest-library
[ta/python-ilorest-library.git] / python-ilorest-library.spec
1 %global sha f6dae68800d20af859ed958c322108604d6a998a
2
3 Name:           python-ilorest-library
4 Version:        v2.3.1.29.gf6dae68
5 Release:        1%{?dist}.1
6 Summary:        HPE RESTful API for iLO is a RESTful application programming interface for the management of iLO and iLO Chassis Manager based HPE servers.
7 License:        %{_platform_license} and ASL 2.0
8 Source0:        https://github.com/HewlettPackard/%{name}/archive/%{sha}.zip
9 Patch0:         0001-initial.patch
10 Vendor:         %{_platform_vendor} and HP
11
12 #Requires: clustermanager-python
13 BuildRequires: python, python-setuptools
14
15 %description
16 HPE RESTful API for iLO is a RESTful application programming interface for the management of iLO and iLO Chassis Manager based HPE servers.
17 REST (Representational State Transfer) is a web based software architectural style consisting of a set of constraints that focuses on a system's resources.
18 iLO REST library performs the basic HTTP operations GET, POST, PUT, PATCH and DELETE on resources using the HATEOAS (Hypermedia as the Engine of Application State) REST architecture.
19 The API allows the clients to manage and interact with iLO through a fixed URL and several URIs. Go to the wiki for more details.
20
21
22 %prep
23 %autosetup -n %{name}-%{sha} -p 1
24
25 #%build
26 #make %{?_smp_mflags}
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 #%make_install
31
32 python setup.py install --root %{buildroot} --no-compile --install-purelib %{_python_site_packages_path} --install-scripts /usr/bin
33
34 %files
35 %{_python_site_packages_path}/redfish
36 %{_python_site_packages_path}/python_ilorest_library-2.3.1-py2.7.egg-info
37
38 %pre
39 # Pre installation (optional)
40
41 %post
42
43 %preun
44 # Pre uninstall (optional)
45 #if [ $1 = 0 ]; then # package is being erased, not upgraded
46 #    /sbin/service food stop > /dev/null 2>&1
47 #    /sbin/chkconfig --del foo
48 #fi
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 # TIPS:
53 # File /usr/lib/rpm/macros contains useful variables which can be used for example to define target directory for man page.
54 # Running "rpm --showrc" command in RHEL host will also show available macros