Added seed code for python-peewee.
[ta/python-peewee.git] / python-peewee.spec
1 #
2 # Spec base taken from
3 # https://src.fedoraproject.org/cgit/rpms/python-peewee.git/tree/python-peewee.spec
4 #
5
6 %global pypi_name peewee
7
8 Name:           python-%{pypi_name}
9 Version:        2.10.2
10 Release:        3%{?dist}
11 Summary:        A small, expressive orm
12
13 License:        MIT
14 URL:            http://github.com/coleifer/peewee/
15 Source0:        https://files.pythonhosted.org/packages/7a/bc/aafce76cae9362dccf70e35c16a6cc11d114ebb640bbb86d76255be5c0d6/peewee-2.10.2.tar.gz
16
17 BuildRequires:  python2-devel
18 BuildRequires:  python2-setuptools
19 BuildRequires:  python2-Cython
20
21 %description
22 A small, expressive ORM written in python with built-in support for sqlite,
23 mysql and postgresql and special extensions like hstore. For flask
24 integration, including an admin interface and RESTful API, check out
25 flask-peewee.
26
27 %package -n python2-%{pypi_name}
28
29 Requires:       python-simplejson
30
31 Summary:        A small, expressive orm
32 %{?python_provide:%python_provide python2-%{pypi_name}}
33
34 %description -n python2-%{pypi_name}
35 A small, expressive ORM written in python with built-in support for sqlite,
36 mysql and postgresql and special extensions like hstore. For flask
37 integration, including an admin interface and RESTful API, check out
38 flask-peewee.
39
40 %prep
41 %setup -q -n %{pypi_name}-%{version}
42
43 %build
44 #%py2_build
45 %{__python2} setup.py build
46
47
48 %install
49 #%py2_install
50 %{__python2} setup.py install --root=$RPM_BUILD_ROOT
51 rm %{buildroot}%{python2_sitearch}/pwiz.*
52 rm %{buildroot}%{_bindir}/pwiz.py
53
54 %files -n python2-%{pypi_name}
55 %license LICENSE
56 %{python2_sitearch}/peewee.*
57 %{python2_sitearch}/%{pypi_name}-%{version}-py?.?.egg-info
58 %{python2_sitearch}/playhouse
59 %{_bindir}/pskel
60
61
62 %changelog
63 * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.10.1-3
64 - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
65
66 * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.10.1-2
67 - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
68
69 * Wed May 10 2017 Fedora Release Monitoring  <release-monitoring@fedoraproject.org> - 2.10.1-1
70 - Update to 2.10.1 (#1448980)
71
72 * Mon Apr 10 2017 Viliam Krizan <vkrizan@redhat.com> - 2.9.2-1
73 - Update to 2.9.2
74
75 * Fri Mar 03 2017 Viliam Krizan <vkrizan@redhat.com> - 2.8.8-1
76 - Update to 2.8.8
77
78 * Tue Feb 07 2017 Viliam Krizan <vkrizan@redhat.com> - 2.8.5-2
79 - Backport upstream fix to force limit and offset to be numeric
80
81 * Mon Jan 09 2017 Charalampos Stratakis <cstratak@redhat.com> - 2.8.5-1
82 - Update to 2.8.5
83
84 * Mon Dec 19 2016 Miro HronĨok <mhroncok@redhat.com> - 2.8.2-4
85 - Rebuild for Python 3.6
86
87 * Thu Nov 10 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.8.2-3
88 - Make pskel script install under usr/bin/
89 - Remove bytecompiled pwiz files
90
91 * Fri Nov 04 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.8.2-2
92 - Change runtime requirement from python2-simplejson to python-simplejson
93
94 * Wed Nov 02 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.8.2-1
95 - Update to 2.8.2
96 - Changed the installation directories to be arch dependent as the package
97 is now compiled using Cython
98
99 * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.2-6
100 - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
101
102 * Mon Jun 06 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.3.2-5
103 - Fix shebangs so python 2 is not dragged with the python 3 subpackage
104 - Build documentation
105
106 * Thu Jun 02 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.3.2-4
107 - Provide Python 3 subpackage
108 - Move binaries to Python 3 subpackage
109 - Modernize SPEC
110
111 * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.2-3
112 - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
113
114 * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.2-2
115 - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
116
117 * Mon Sep 29 2014 Matej Stuchlik <mstuchli@redhat.com> - 2.3.2-1
118 - Update to 2.3.2
119
120 * Wed Aug 27 2014 Matej Stuchlik <mstuchli@redhat.com> - 2.3.1-1
121 - Update to 2.3.1
122
123 * Mon Jun 09 2014 Matej Stuchlik <mstuchli@redhat.com> - 2.2.4-1
124 - Update to 2.2.4
125
126 * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.7-2
127 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
128
129 * Thu Jan 09 2014 Matej Stuchlik <mstuchli@redhat.com> - 2.1.7-1
130 - Update to 2.1.7
131
132 * Tue Aug 13 2013 Matej Stuchlik <mstuchli@redhat.com> - 2.1.4-2
133 - Added patch increasing timeout in concurrency test
134
135 * Wed Aug 07 2013 Matej Stuchlik <mstuchli@redhat.com> - 2.1.4-1
136 - Updated to 2.1.4
137
138 * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.9-3
139 - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
140
141 * Tue Apr 02 2013 Matej Stuchlik <mstuchli@redhat.com> - 2.0.9-2
142 - Review fixes
143
144 * Fri Mar 29 2013 mstuchli <mstuchli@redhat.com> - 2.0.9-1
145 - Initial spec