9698333f0e3f572023f7e2cc49ffc0bf0e26be48
[ta/storage.git] / partfs_rootdisk.spec
1 # Copyright 2019 Nokia
2   
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 %define RPM_MINOR_VERSION 2
16
17 Name:       partfs_rootdisk
18 Version:    %{_version}
19 Release:    %{RPM_MINOR_VERSION}%{?dist}
20 Summary:    partfs_rootdisk
21 License:    %{_platform_license}
22 Source0:    %{name}-%{version}.tar.gz
23 Vendor:     %{_platform_vendor}
24 BuildArch:  noarch
25
26 %description
27 Configure root disk partitions
28
29 %prep
30 %autosetup
31
32 %build
33
34 %install
35 mkdir -p %{buildroot}/etc/opt/localstorage
36 rsync -av partfs_rootdisk/localstorage/* %{buildroot}/etc/opt/localstorage
37
38 %files
39 /etc/opt/localstorage
40
41 %post