Fix: First boot from floppy, not CD-ROM
[ta/remote-installer.git] / remote-installer.spec
1 # Copyright 2019 Nokia
2 #
3 # Licensed under the Apache License, Version 2.0 (the "License");
4 # you may not use this file except in compliance with the License.
5 # You may obtain a copy of the License at
6 #
7 #     http://www.apache.org/licenses/LICENSE-2.0
8 #
9 # Unless required by applicable law or agreed to in writing, software
10 # distributed under the License is distributed on an "AS IS" BASIS,
11 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
12 # See the License for the specific language governing permissions and
13 # limitations under the License.
14
15 Name:           remote-installer
16 Version:        %{_version}
17 Release:        1%{?dist}
18 Summary:        Contains components for the remote-installer
19 Group:          %{_platform_group}
20 License:        %{_platform_licence}
21 Source0:        %{name}-%{version}.tar.gz
22 Vendor:         %{_platform_vendor}
23
24 BuildArch:      noarch
25
26 # BuildRequires:  docker
27
28 %description
29 Contains components for the remote-installer
30
31 %prep
32
33 %build
34 docker build \
35   --network=host \
36   --no-cache \
37   --force-rm \
38   --build-arg HTTP_PROXY="${http_proxy}" \
39   --build-arg HTTPS_PROXY="${https_proxy}" \
40   --build-arg NO_PROXY="${no_proxy}" \
41   --build-arg http_proxy="${http_proxy}" \
42   --build-arg https_proxy="${https_proxy}" \
43   --build-arg no_proxy="${no_proxy}" \
44   --tag remote-installer \
45   --file docker-build/remote-installer/Dockerfile .
46
47 # Here hould be some registry but it should be handled by a Jenkis job
48 docker image save remote-installer >remote-installer-image.tar
49
50 %files